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T3RRA software crashes without an error message

Symptoms:

The T3RRA software will suddenly close with no warning or error message. It is not clear what has caused the program to do this. Alternatively, the program will freeze with the splash screen showing or not start at all.


Cause:

Some unhandled error is causing the program to suddenly halt.  


Solution:

If the issue occurs on startup, or you are on an old version, updating can help. Sometimes an older version will run well enough to access the update function. To 'downgrade', right-click on the desktop shortcut and choose "Open file location". In that folder there should be two or more folders starting with "app-" (e.g. "app-2024.9.2"). In older products, there will be a "v" folder containing two or more folders with numbers for names (e.g. "0" and "2.233"). The larger the folder number, the more recent the release. Move the most recent release folder to a temporary location (e.g. Desktop) and restart the program. If it starts normally, open "Settings" and click "Download updates". Don't forget to delete the folder from the temporary location (or restore it if it doesn't help). If the issue persists, try rerunning the installer.


If a certain action by you causes the crash, try to avoid that action. Normally this type of error requires our software developers to develop a fix and release an updated version of the software. However, this type of error is difficult to reproduce and hence difficult to fix. Follow the following steps to send the information the developers will need.


  1. Open the Windows ‘Event Viewer’ program 
  2. In the left pane navigate to “Windows Logs > Application”
  3. Find the most recent errors in the right pane that are related to the crash
    1. Normally these errors will occur in pairs with the first one having the source “Application Error” and the second having the source “.NET Runtime”. It is the second one that is of interest normally.
    2. Copy the contents to the “.NET Runtime” error into an email and send it to support@t3rra.com

         (image above: finding the errors in windows logs.)

         (Image above: highlighted contents that should be sent to T3RRA.)