Access to the port ‘COM X’ is denied.
See also: “Mouse Pointer flickers across screen randomly”.
Symptoms:
The following message appears.
Cause:
This message generally occurs when an attempt is made to open a serial connection to iGrade or directly to a GPS, but the serial port in question is already being used by another piece of software.
Solutions:
- Check that no other software is running on the tablet and already using the port.
- Check the connection of the cable to the tablet.
- Power down the tablet running T3RRA and the tractor. Next, remove the serial cable or USB-Serial cable from the tablet. Turn on the tablet and start T3RRA. Once you are looking at the GPS screen, plug in the cable. Now, start up the tractor.
Plug all cables for iGrade in before starting the tractor. In other words, the tractor needs to be OFF until iGrade is plugged in and the T3RRA tablet is powered on.
The tablets that do not have true dedicated serial ports require USB-to-serial cables which create 'virtual' COM ports. Best practice is to update the USB-to-serial cable driver before initial use of T3RRA in-field.
Steps:
- Turn on the tablet that has T3RRA installed.
- Connect to the internet.
- Insert your USB to Serial cable.
- Select Settings, then GPS Port settings, click on 'Device Manager'.
- When the Device Manager window opens, locate 'Ports (COM & LPT)'.*
- Click on 'Ports (COM & LPT)' to show which COM port has been assigned.
- Right click on 'COM Port'.
- Select 'Update Driver'. You will be notified once the software has been updated or if it has the current driver.
- Set the COM port in T3RRA GPS Port Settings to correct port from the drop down.
*NOTE: If ‘Port” is not in the list, you may need to download the driver from the product website and install manually. We ONLY recommend FTDI USB to Serial Port adapters. This is the URL to download the FTDI Setup executable file: https://ftdichip.com/wp-content/uploads/2021/08/CDM212364_Setup.zip