Skip to main content

T3RRA software is not updating

Symptoms:

When attempting to update T3RRA software using the normal method in the Settings area an error message like the following appears. You appear to have a good internet connection.

Cause:

If you are on a corporate network it might be configured not to allow access to certain websites. Our download server may not be on an approved whitelist.


Solution:

Request help from the company network administrators. Alternatively switch to another network (such as by tethering the tablet to your phone’s internet signal).