# Baud rate is set correctly but messages from iGrade are still garbled.
**Symptoms**:
Baud rates are set correctly on both T3RRA software and in iGrade. The T3RRA software is not receiving GPS and the GPS diagnostics window is showing an unintelligible data stream.

**Causes**:
The serial connection is not properly grounded. Pin 5 is disconnected or connected to the wrong pin at the other end of the cable.
**Solutions**:
Carefully check the remote control cable and the iGrade harness. Ensure that the ground wire is properly grounded. In at least one case we have had a user report that an additional grounding wire was required as shown below.
