Software Issues

T3RRA Xxxxx is not happy :-( error.

Symptoms:

The following error (or similar) appears.

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Cause:

There is a problem with T3RRAs program file structure. The program cannot find the correct path to the latest program files when it is started up. 


Solution:

Contact T3RRA or your dealer. Please provide context about when this error started happening and whether or not any changes were recently made to the tablet.

Out of memory errors

Symptoms:

T3RRA software crashes with an “Out of Memory” error.


Cause:

If the software is running on a 32bit version of Windows 10 and is working with large data sets it is possible to get this error.


Solution:

Upgrade your Windows 10 operating system to the 64bit version.

T3RRA software crashes without an error message

Symptoms:

The T3RRA software will suddenly close with no warning or error message. It is not clear what has caused the program to do this. Alternatively, the program will freeze with the splash screen showing or not start at all.


Cause:

Some unhandled error is causing the program to suddenly halt.  


Solution:

If the issue occurs on startup, or you are on an old version, updating can help. Sometimes an older version will run well enough to access the update function. To 'downgrade', right-click on the desktop shortcut and choose "Open file location". In that folder there should be two or more folders starting with "app-" (e.g. "app-2024.9.2"). In older products, there will be a "v" folder containing two or more folders with numbers for names (e.g. "0" and "2.233"). The larger the folder number, the more recent the release. Move the most recent release folder to a temporary location (e.g. Desktop) and restart the program. If it starts normally, open "Settings" and click "Download updates". Don't forget to delete the folder from the temporary location (or restore it if it doesn't help). If the issue persists, try rerunning the installer.


If a certain action by you causes the crash, try to avoid that action. Normally this type of error requires our software developers to develop a fix and release an updated version of the software. However, this type of error is difficult to reproduce and hence difficult to fix. Follow the following steps to send the information the developers will need.


  1. Open the Windows ‘Event Viewer’ program 
  2. In the left pane navigate to “Windows Logs > Application”
  3. Find the most recent errors in the right pane that are related to the crash
    1. Normally these errors will occur in pairs with the first one having the source “Application Error” and the second having the source “.NET Runtime”. It is the second one that is of interest normally.
    2. Copy the contents to the “.NET Runtime” error into an email and send it to support@t3rra.com

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         (image above: finding the errors in windows logs.)

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         (Image above: highlighted contents that should be sent to T3RRA.)

Unauthorized Access Exception on program exit

Symptoms:

Bozo Error message occurs upon Exit prohibiting close of T3RRA software.

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Cause:

Current “User” of the tablet does not have access to T3RRA Program Data in folder.

Solution:

  1. Maneuver to the location -  C:\ProgramData\T3RRA\T3RRA Cutta\Settings\T3RRA Cutta Saved Settings.xml
  2. Right click on T3RRA Cutta saved settings file.
  3. Choose Properties
  4. Choose Security tab
  5. Choose Advanced
  6. In Permissions tab Click Add
  7. Choose select a principle
  8. Type in name of User to add
  9. Select Ok
  10. Check Full control permissions
  11. Select Ok
  12. Select Apply

‘Out of memory’ error when saving

Symptoms:

Attempting to save a project causes an ‘Out of Memory’ error and no file is saved. This error will also occur periodically when auto-saves occur. This error will completely disrupt your ability to use the T3RRA software. Prior to the error occurring you may have noticed the project getting progressively slower and slower to load. If you run Task Manager you will see that the project is using excessive amounts of memory while loading.

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Cause:

There is a bug in earlier software versions that causes replication of unnecessary data within the project each time a save occurs. Eventually this will bloat the project file to the extent that internal variables can no longer process the data objects that exceed memory limits.


Solutions:

Upgrade your software to at least v2.137. Load the offending project (it may take a long time to load) and then save it again. The project will have offending data sections removed and now should go back to normal load time on subsequent loads.